graphql-java/graphql-java · Security

graphql-java vulnerable to Denial of Service via GraphQL query that consumes CPU resources

GHSA ID
GHSA-v62j-cxhh-fq22
CVE ID
CVE-2022-37734
Severity
high
Published
Updated
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS v3
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

graphql-java before 19.0, 18.3, and 17.4 is vulnerable to Denial of Service. An attacker send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0, 18.3, and 17.4.

CWEs

References