guzzle/oauth-subscriber · Security

Guzzle OAuth Subscriber has insufficient nonce entropy

GHSA ID
GHSA-237r-r8m4-4q88
CVE ID
CVE-2025-21617
Severity
medium
Published
Updated
CVSS v4
6.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Description

Impact

Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source (https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192). This can leave servers vulnerable to replay attacks when TLS is not used.

Patches

Upgrade to version 0.8.1 or higher.

Workarounds

No.

References

Issue is similar to https://nvd.nist.gov/vuln/detail/CVE-2025-22376.

CWEs

References