hyperledger/indy-node · Security

Indy's NODE_UPGRADE transaction vulnerable to remote code execution

GHSA ID
GHSA-r6v9-p59m-gj2p
CVE ID
CVE-2022-31020
Severity
high
Published
Updated
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS v3
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS v4
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

Impact

The pool-upgrade request handler in Indy-Node <=1.12.4 allows an improperly authenticated attacker to remotely execute code on nodes within the network.

Network operators are strongly encouraged to upgrade to the latest Indy-Node release >=1.12.5 as soon as possible.

Patches

The pool-upgrade request handler in Indy-Node >=1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution.

Mitigations

Network operators are strongly encouraged to upgrade to the latest Indy-Node release >=1.12.5 as soon as possible.

Acknowledgements

Thank you to @shakreiner at CyberArk Labs for finding and responsibly disclosing this issue.

CWEs

References