ipfs/js-ipfs-bitswap · Security

Denial of Service in ipfs-bitswap

GHSA ID
GHSA-6fcr-9h9g-23fq
Severity
medium
Published
Updated
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS v3
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Versions of ipfs-bitswap prior to 0.24.1 are vulnerable to Denial of Service (DoS). The package put unwanted blocks in the blockstore, which could be used to exhaust system resources in specific conditions.

Recommendation

Upgrade to version 0.24.1 or later.

CWEs

References