janssenproject/jans · Security

Janssen Config API returns results without scope verification

GHSA ID
GHSA-373j-mhpf-84wg
CVE ID
CVE-2025-53003
Severity
high
Published
Updated
CVSS v4
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Description

Impact

What kind of vulnerability is it? Who is impacted? The configAPI is an internal service and hence should never be exposed to the internet. With that said, this is a serious vulnerability that has a large internal surface attack area that exposes all sorts of information from the IDP including clients, users, scripts ..etc.

This affects all users of Janssen <1.8.0 and Gluu Flex <5.8.0

Patches

Has the problem been patched? What versions should users upgrade to? All users are advised to upgrade immediately to 1.8.0 for Janssen users and 5.8.0 For Flex users.

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading? The user can potentially fork and build the config api and patch it in their system following the commit here https://github.com/JanssenProject/jans/commit/92eea4d4637f1cae16ad2f07b2c16378ff3fc5f1

References

Are there any links users can visit to find out more? https://github.com/JanssenProject/jans/issues/11575 https://github.com/JanssenProject/jans/commit/92eea4d4637f1cae16ad2f07b2c16378ff3fc5f1

CWEs

References