jenkinsci/crx-content-package-deployer-plugin · Security
Jenkins CRX Content Package Deployer Plugin subject to Cross-Site Request Forgery
- GHSA ID
- GHSA-62fp-j75q-mqhc
- CVE ID
- CVE-2019-10437
- Severity
- high
- Published
- Updated
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CVSS v3
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Description
A cross-site request forgery vulnerability in Jenkins CRX Content Package Deployer Plugin prior to 1.9 allowed attackers to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. This issue is patched in version 1.9
CWEs
- CWE-352 · Cross-Site Request Forgery (CSRF)