joeattardi/emoji-button · Security
Cross-Site Scripting Vulnerability in @joeattardi/emoji-button
- GHSA ID
- GHSA-f34m-x9pj-62vq
- CVE ID
- CVE-2021-43785
- Severity
- high
- Published
- Updated
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L
- CVSS v3
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L
Description
Impact
There are two vectors for XSS attacks with versions of @joeattardi/emoji-button before 4.6.2:
- A URL for a custom emoji
- An i18n string
In both of these cases, a value can be crafted such that it can insert a script tag into the page and execute malicious code.
Patches
This vulnerability is fixed starting in version 4.6.2. This is resolved by properly escaping strings that are inserted into the HTML document.
Workarounds
There is no workaround other than upgrading to a non-vulnerable version.
Credit
This issue was discovered by GitHub team member @erik-krogh (Erik Krogh Kristensen) and was reported by the GitHub Security Lab team.
CWEs
- CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
References
- https://github.com/joeattardi/emoji-button/security/advisories/GHSA-f34m-x9pj-62vq ↗
- https://nvd.nist.gov/vuln/detail/CVE-2021-43785 ↗
- https://github.com/joeattardi/emoji-button/commit/05970c09180cd27fff493e998ac5bf0468b1bb16 ↗
- https://github.com/joeattardi/emoji-button/commit/fe54bef107eb3f74873a4018f2ff49fa124c6a2e ↗
- https://github.com/advisories/GHSA-f34m-x9pj-62vq ↗