magento/magento2 · Security
Magento 2 Community Edition XML Injection
- GHSA ID
- GHSA-8p5c-f836-m4h7
- CVE ID
- CVE-2019-8158
- Severity
- critical
- Published
- Updated
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS v3
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
An XPath entity injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An attacker can craft a GET request to page cache block rendering module that gets passed to XML data processing engine without validation. The crafted key/value GET request data allows an attacker to limited access to underlying XML data.
As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
CWEs
- CWE-91 · XML Injection (aka Blind XPath Injection)
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-8158 ↗
- https://web.archive.org/web/20220121051105/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update ↗
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8158.yaml ↗
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update ↗
- https://github.com/advisories/GHSA-8p5c-f836-m4h7 ↗