melisplatform/melis-front · Security

melisplatform/melis-front vulnerable to deserialization of untrusted data

GHSA ID
GHSA-h479-2mv4-5c26
CVE ID
CVE-2022-39298
Severity
high
Published
Updated
CVSS
7.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
CVSS v3
7.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L

Description

Impact

Attackers can deserialize arbitrary data on affected versions of melisplatform/melis-front, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication.

Users should immediately upgrade to melisplatform/melis-front >= 5.0.1.

Patches

This issue was addressed by restricting allowed classes when deserializing user-controlled data.

References

For more information

If you have any questions or comments about this advisory, you can contact:

  • The original reporters, by sending an email to vulnerability.research [at] sonarsource.com;
  • The maintainers, by opening an issue on this repository.

CWEs

References