modelcontextprotocol/inspector · Security

MCP Inspector proxy server lacks authentication between the Inspector client and proxy

GHSA ID
GHSA-7f8r-222p-6f5g
CVE ID
CVE-2025-49596
Severity
critical
Published
Updated
CVSS v4
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Description

Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.

Credit: Rémy Marot [email protected]

CWEs

References