mpetroff/pannellum · Security

Pannellum Cross-Site Scripting due to data not being sanitized for URIs or vbscript

GHSA ID
GHSA-m52x-29pq-w3vv
CVE ID
CVE-2019-16763
Severity
medium
Published
Updated
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:N
CVSS v3
4.8 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:N

Description

Versions of pannellum prior to 2.5.6 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize URLs for data URIs, which may allow attackers to execute arbitrary code in a victim's browser.

Recommendation

Upgrade to version 2.5.6 or later.

CWEs

References