nette/application · Security
Potential Remote Code Execution vulnerability
- GHSA ID
- GHSA-8gv3-3j7f-wg94
- CVE ID
- CVE-2020-15227
- Severity
- high
- Published
- Updated
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N
- CVSS v3
- 8.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N
Description
Packages nette/application versions prior to 2.2.10, 2.3.14, 2.4.16, 3.0.6 and nette/nette versions prior to 2.0.19 and 2.1.13 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE.
Reported by Cyku Hong from DEVCORE (https://devco.re)
Impact
Code injection, possible remote code execution.
Patches
Fixed in nette/application 2.2.10, 2.3.14, 2.4.16, 3.0.6 and nette/nette 2.0.19 and 2.1.13
CWEs
- CWE-74 · Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
- CWE-94 · Improper Control of Generation of Code ('Code Injection')
References
- https://github.com/nette/application/security/advisories/GHSA-8gv3-3j7f-wg94 ↗
- https://packagist.org/packages/nette/application ↗
- https://packagist.org/packages/nette/nette ↗
- https://nvd.nist.gov/vuln/detail/CVE-2020-15227 ↗
- https://lists.debian.org/debian-lts-announce/2021/04/msg00003.html ↗
- https://blog.nette.org/en/cve-2020-15227-potential-remote-code-execution-vulnerability ↗
- https://github.com/FriendsOfPHP/security-advisories/blob/master/nette/application/CVE-2020-15227.yaml ↗
- https://github.com/advisories/GHSA-8gv3-3j7f-wg94 ↗