openclaw/openclaw · Security

OpenClaw: Incomplete host-env-security-policy allows untrusted model to substitute compiler binaries via env overrides

GHSA ID
GHSA-g8xp-qx39-9jq9
CVE ID
CVE-2026-41373
Severity
high
Published
Updated
CVSS
6.1 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
CVSS v3
6.1 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
CVSS v4
7.3 · CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

Summary

Incomplete host-env-security-policy.json allows untrusted model to substitute compiler binaries (CC, CXX, CARGO_BUILD_RUSTC, CMAKE_C_COMPILER) via env overrides on approved host exec requests

Current Maintainer Triage

  • Status: narrow
  • Normalized severity: medium
  • Assessment: Shipped v2026.3.28 host-env policy missed compiler override vars, but exploitation still requires an approved host-exec request inside the existing exec trust domain, so medium not high.

Affected Packages / Versions

  • Package: openclaw (npm)
  • Latest published npm version: 2026.3.31
  • Vulnerable version range: <=2026.3.28
  • Patched versions: >= 2026.3.31
  • First stable tag containing the fix: v2026.3.31

Fix Commit(s)

  • e277a37f896b5011a1df06e6490c6630074d0afa — 2026-03-30T20:06:32+01:00

OpenClaw thanks @tdjackey for reporting.

CWEs

References