opensource-workshop/connect-cms · Security
Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View
- GHSA ID
- GHSA-cmfh-mpmf-fmq4
- CVE ID
- CVE-2026-32277
- Severity
- high
- Published
- Updated
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- CVSS v3
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
Description
Security Advisory — Cabinet Plugin (DOM-based XSS)
Summary
A DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view.
Affected Versions
- 1.x series: >= 1.35.0, <= 1.41.0
- 2.x series: >= 2.35.0, <= 2.41.0
Patched Versions
- 1.41.1
- 2.41.1
Description
In the Cabinet Plugin list view, DOM-based Cross-Site Scripting (XSS) could occur due to how saved names were rendered. If exploited, arbitrary script could run in the victim's browser, which may lead to unauthorized actions or information theft. Exploitation requires that the attacker be able to reach the affected functionality as an authenticated user. Users affected by this vulnerability should update to a fixed version.
Solution
Update to the fixed version. For the 1.x series, update to 1.41.1 or later. For the 2.x series, update to 2.41.1 or later.
Credits
OpenSource WorkShop thanks Sho Odagiri (小田切 祥) of GMO Cybersecurity by Ierae, Inc. for reporting this vulnerability.
CWEs
- CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
References
- https://github.com/opensource-workshop/connect-cms/security/advisories/GHSA-cmfh-mpmf-fmq4 ↗
- https://github.com/opensource-workshop/connect-cms/commit/c04dc40f814eff891915752ef1ec00ba6612441c ↗
- https://github.com/opensource-workshop/connect-cms/releases/tag/v1.41.1 ↗
- https://github.com/opensource-workshop/connect-cms/releases/tag/v2.41.1 ↗
- https://nvd.nist.gov/vuln/detail/CVE-2026-32277 ↗
- https://github.com/advisories/GHSA-cmfh-mpmf-fmq4 ↗