packbackbooks/lti-1-3-php-library · Security
LTI 1.3 Tool Library's function used to generate random nonces not sufficiently cryptographically complex before v5.0
- GHSA ID
- GHSA-768m-5w34-2xf5
- CVE ID
- CVE-2022-31157
- Severity
- high
- Published
- Updated
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CVSS v3
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Description
Impact
The function used to generate random nonces was not sufficiently cryptographically complex. As a result values may be predictable and tokens may be forgable.
Patches
Users should upgrade to version 5.0 immediately
Workarounds
None.
CWEs
- CWE-327 · Use of a Broken or Risky Cryptographic Algorithm
- CWE-330 · Use of Insufficiently Random Values
References
- https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-768m-5w34-2xf5 ↗
- https://github.com/packbackbooks/lti-1-3-php-library/commit/de19e8a0b28cdc7750fa3ca98471eeed26ba3e57 ↗
- https://openid.net/specs/openid-connect-core-1_0.html#IDToken ↗
- https://nvd.nist.gov/vuln/detail/CVE-2022-31157 ↗
- https://github.com/advisories/GHSA-768m-5w34-2xf5 ↗