parse-community/parse-server · Security

Parse Server before v3.4.1 vulnerable to Denial of Service

GHSA ID
GHSA-2479-qvv7-47qq
CVE ID
CVE-2019-1020012
Severity
high
Published
Updated
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS v3
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Impact

If a POST request is made to /parse/classes/_Audience (or other volatile class), any subsuquent POST requests result in an internal server error (500).

Patches

Afflicted installations will also have to remove the offending collection from their database.

Yes, patched in 3.4.1

Workarounds

Yes, user can apply: https://github.com/parse-community/parse-server/commit/8709daf698ea69b59268cb66f0f7cee75b52daa5

References

Nothing other than this advisory at this time

For more information

If you have any questions or comments about this advisory:

CWEs

References