payloadcms/payload · Security

Payload didn't enforce field-level password update restrictions

GHSA ID
GHSA-fx49-4h83-wjv9
CVE ID
CVE-2026-105855
Severity
high
Published
Updated
CVSS v4
7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Description

Impact

When an auth collection defined a field-level access.update restriction on the password field, the restriction was not enforced on the server correctly.

Patches

Users should upgrade Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.

CWEs

References