payloadcms/payload · Security

Payload Form Builder has an RCE issue

GHSA ID
GHSA-r488-j9vj-wx3q
CVE ID
CVE-2026-105857
Severity
critical
Published
Updated
CVSS
10 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
CVSS v3
10 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Description

Impact

A vulnerability in @payloadcms/plugin-form-builder in versions < 3.90.0 allow submissions which could be crafted to execute remote code on the server.

You are affected if:

  • You are using @payloadcms/plugin-form-builder

Patches

Users should upgrade Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.

CWEs

References