phpmussel/phpmussel · Security

Phar unserialization vulnerability in phpMussel

GHSA ID
GHSA-qr95-4mq5-r3fh
CVE ID
CVE-2020-4043
Severity
high
Published
Updated
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
CVSS v3
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N

Description

Impact

What kind of vulnerability is it? Who is impacted?

Anyone using >= v1.0.0 < v1.6.0.

Patches

Has the problem been patched? What versions should users upgrade to?

Yes. Upgrading to at least >= v1.6.0 (the earliest safe version) will resolve the problem. However, as multiple new major versions have been released since that version, upgrading to the latest available version is recommended, in order to protect against any potential future vulnerabilities, unknown at the time of writing this advisory.

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

Yes. In the package's configuration, disable archive checking by setting check_archives to false (thus avoiding execution of the affected parts of the codebase entirely).

References

Are there any links users can visit to find out more?

Yes. The vulnerability is documented at SECURITY.md and also at #167.

For more information

If you have any questions or comments about this advisory:

CWEs

References