pypa/setuptools · Security
pypa/setuptools vulnerable to Regular Expression Denial of Service (ReDoS)
- GHSA ID
- GHSA-r9hx-vwmv-q579
- CVE ID
- CVE-2022-40897
- Severity
- high
- Published
- Updated
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS v3
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS v4
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:L/SI:L/SA:N
Description
Python Packaging Authority (PyPA)'s setuptools is a library designed to facilitate packaging Python projects. Setuptools version 65.5.0 and earlier could allow remote attackers to cause a denial of service by fetching malicious HTML from a PyPI package or custom PackageIndex page due to a vulnerable Regular Expression in package_index. This has been patched in version 65.5.1.
CWEs
- CWE-1333 · Inefficient Regular Expression Complexity
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-40897 ↗
- https://github.com/pypa/setuptools/blob/fe8a98e696241487ba6ac9f91faa38ade939ec5d/setuptools/package_index.py#L200 ↗
- https://github.com/pypa/setuptools/issues/3659 ↗
- https://github.com/pypa/setuptools/commit/43a9c9bfa6aa626ec2a22540bea28d2ca77964be ↗
- https://github.com/pypa/setuptools/compare/v65.5.0...v65.5.1 ↗
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ADES3NLOE5QJKBLGNZNI2RGVOSQXA37R ↗
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YNA2BAH2ACBZ4TVJZKFLCR7L23BG5C3H ↗
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ADES3NLOE5QJKBLGNZNI2RGVOSQXA37R ↗
- https://lists.fedoraproject.org/archives/list/[email protected]/message/YNA2BAH2ACBZ4TVJZKFLCR7L23BG5C3H ↗
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages ↗
- https://pyup.io/vulnerabilities/CVE-2022-40897/52495 ↗
- https://security.netapp.com/advisory/ntap-20230214-0001 ↗
- https://security.netapp.com/advisory/ntap-20240621-0006 ↗
- https://setuptools.pypa.io/en/latest ↗
- https://github.com/pypa/advisory-database/tree/main/vulns/setuptools/PYSEC-2022-43012.yaml ↗
- https://lists.debian.org/debian-lts-announce/2024/09/msg00018.html ↗
- https://github.com/advisories/GHSA-r9hx-vwmv-q579 ↗