rancher/wrangler · Security
Denial of service (DoS) when processing Git credentials
- GHSA ID
- GHSA-8fcj-gf77-47mg
- CVE ID
- CVE-2022-43756
- Severity
- medium
- Published
- Updated
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
- CVSS v3
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
Description
Impact
A denial of services (DoS) vulnerability was discovered in Wrangler Git package affecting versions up to and including v1.0.0.
Specially crafted Git credentials can result in a denial of service (DoS) attack on an application that uses Wrangler due to the exhaustion of the available memory and CPU resources. This is caused by a lack of input validation of Git credentials before they are used, which may lead to a denial of service in some cases. This issue can be triggered when accessing both private and public Git repositories.
Workarounds
A workaround is to sanitize input passed to the Git package to remove potential unsafe and ambiguous characters. Otherwise, the best course of action is to update to a patched Wrangler version.
Patches
Patched versions include v1.0.1 and later and the backported tags - v0.7.4-security1, v0.8.5-security1 and v0.8.11.
For more information
If you have any questions or comments about this advisory:
- Reach out to SUSE Rancher Security team for security related inquiries.
- Open an issue in Rancher or Wrangler repository.
- Verify our support matrix and product support lifecycle.
CWEs
- CWE-74 · Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
- CWE-150 · Improper Neutralization of Escape, Meta, or Control Sequences
References
- https://github.com/rancher/wrangler/security/advisories/GHSA-8fcj-gf77-47mg ↗
- https://nvd.nist.gov/vuln/detail/CVE-2022-43756 ↗
- https://bugzilla.suse.com/show_bug.cgi?id=1205296 ↗
- https://github.com/rancher/wrangler/commit/341018c8fef3e12867c7cb2649bd2cecac75f287 ↗
- https://github.com/advisories/GHSA-8fcj-gf77-47mg ↗
- https://github.com/rancher/rancher/security/policy ↗
- https://pkg.go.dev/vuln/GO-2023-1515 ↗