sebhildebrandt/systeminformation · Security
systeminformation SSID Command Injection Vulnerability
- GHSA ID
- GHSA-gx6r-qc2v-3p3v
- CVE ID
- CVE-2023-42810
- Severity
- critical
- Published
- Updated
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS v3
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Impact
SSID Command Injection Vulnerability
Patches
Problem was fixed with a parameter check. Please upgrade to version >= 5.21.7, Version 4 was not affected
Workarounds
If you cannot upgrade, be sure to check or sanitize parameter strings that are passed to wifiConnections(), wifiNetworks() (string only)
References
CWEs
- CWE-77 · Improper Neutralization of Special Elements used in a Command ('Command Injection')
References
- https://github.com/sebhildebrandt/systeminformation/security/advisories/GHSA-gx6r-qc2v-3p3v ↗
- https://github.com/sebhildebrandt/systeminformation/commit/7972565812ccb2a610a22911c54c3446f4171392 ↗
- https://systeminformation.io/security.html ↗
- https://nvd.nist.gov/vuln/detail/CVE-2023-42810 ↗
- https://github.com/advisories/GHSA-gx6r-qc2v-3p3v ↗