snawoot/postfix-mta-sts-resolver · Security
postfix-mta-sts-resolver Algorithm Downgrade vulnerability
- GHSA ID
- GHSA-h92m-42h4-82f6
- CVE ID
- CVE-2019-16791
- Severity
- high
- Published
- Updated
- CVSS
- 6.9 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N
- CVSS v3
- 6.9 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N
- CVSS v4
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N
Description
Incorrect query parsing
Impact
All users of versions prior to 0.5.1 can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.
Patches
Problem has been patched in version 0.5.1
Workarounds
Users may remediate this vulnerability without upgrading by applying these patches to older suppoorted versions.
For more information
If you have any questions or comments about this advisory:
- Open an issue in postfix-mta-sts-resolver repo
- Email me at vladislav at vm-0 dot com
CWEs
- CWE-757 · Selection of Less-Secure Algorithm During Negotiation ('Algorithm Downgrade')
References
- https://github.com/Snawoot/postfix-mta-sts-resolver/security/advisories/GHSA-h92m-42h4-82f6 ↗
- https://nvd.nist.gov/vuln/detail/CVE-2019-16791 ↗
- https://gist.github.com/Snawoot/b9da85d6b26dea5460673b29df1adc6b ↗
- https://github.com/pypa/advisory-database/tree/main/vulns/postfix-mta-sts-resolver/PYSEC-2020-174.yaml ↗
- https://github.com/advisories/GHSA-h92m-42h4-82f6 ↗