stchris/untangle · Security
untangle vulnerable to XML Entity Expansion
- GHSA ID
- GHSA-7xr3-6ggc-wc9p
- CVE ID
- CVE-2022-33977
- Severity
- high
- Published
- Updated
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS v3
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS v4
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Description
Impact
An attacker may be able to cause a denial-of-service (DoS) condition on the server on which the product is running. This affects untangle versions up to and including 1.2.0
Patches
The problem has been fixed with version 1.2.1
Workarounds
None
References
https://jvn.jp/en/jp/JVN30454777/
For more information
If you have any questions or comments about this advisory:
- Open an issue
CWEs
- CWE-776 · Improper Restriction of Recursive Entity References in DTDs ('XML Entity Expansion')
References
- https://github.com/stchris/untangle/security/advisories/GHSA-7xr3-6ggc-wc9p ↗
- https://nvd.nist.gov/vuln/detail/CVE-2022-33977 ↗
- https://github.com/pypa/advisory-database/tree/main/vulns/untangle/PYSEC-2022-243.yaml ↗
- https://github.com/stchris/untangle/releases/tag/1.2.1 ↗
- https://jvn.jp/en/jp/JVN30454777 ↗
- https://github.com/advisories/GHSA-7xr3-6ggc-wc9p ↗