stchris/untangle · Security
untangle vulnerable to Improper Restriction of XML External Entity Reference
- GHSA ID
- GHSA-f83q-2cp7-qrjg
- CVE ID
- CVE-2022-31471
- Severity
- high
- Published
- Updated
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CVSS v3
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CVSS v4
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Description
Description
untangle is a python library to convert XML data to python objects. untangle versions 1.2.0 and earlier improperly restricts XML external entity references. By exploiting this vulnerability, a remote unauthenticated attacker may read the contents of local files.
Impact
An attacker may be able to read the contents of local files. This affects untangle versions up to and including 1.2.0
Patches
The problem has been fixed with version 1.2.1
Workarounds
None
References
https://jvn.jp/en/jp/JVN30454777/
For more information
If you have any questions or comments about this advisory:
- Open an issue
CWEs
- CWE-611 · Improper Restriction of XML External Entity Reference
References
- https://github.com/stchris/untangle/security/advisories/GHSA-f83q-2cp7-qrjg ↗
- https://nvd.nist.gov/vuln/detail/CVE-2022-31471 ↗
- https://github.com/pypa/advisory-database/tree/main/vulns/untangle/PYSEC-2022-244.yaml ↗
- https://github.com/stchris/untangle/releases/tag/1.2.1 ↗
- https://jvn.jp/en/jp/JVN30454777 ↗
- https://github.com/advisories/GHSA-f83q-2cp7-qrjg ↗