strapi/strapi · Security

Command Injection in strapi

GHSA ID
GHSA-9p2w-rmx4-9mw7
CVE ID
CVE-2019-19609
Severity
high
Published
Updated
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
CVSS v3
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Description

Versions of strapi before 3.0.0-beta.17.8 are vulnerable to Command Injection. The package fails to sanitize plugin names in the /admin/plugins/install/ route. This may allow an authenticated attacker with admin privileges to run arbitrary commands in the server.

Recommendation

Upgrade to version 3.0.0-beta.17.8 or later

CWEs

References