tojocky/node-printer · Security

Potential Command Injection in printer

GHSA ID
GHSA-5c8j-xr24-2665
CVE ID
CVE-2014-3741
Severity
critical
Published
Updated
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS v3
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Versions 0.0.1 and earlier of printer are affected by a command injection vulnerability resulting from a failure to sanitize command arguments properly in the printDirect() function.

Recommendation

Update to version 0.0.2 or later.

CWEs

References