tootallnate/node-https-proxy-agent · Security

Denial of Service in https-proxy-agent

GHSA ID
GHSA-8g7p-74h8-hg48
CVE ID
CVE-2018-3739
Severity
critical
Published
Updated
CVSS
9.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVSS v3
9.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Description

Versions of https-proxy-agent before 2.2.0 are vulnerable to denial of service. This is due to unsanitized options (proxy.auth) being passed to Buffer().

Recommendation

Update to version 2.2.0 or later.

CWEs

References