tygo-van-den-hurk/slyde · Security

Improper Control of Generation of Code ('Code Injection') in @tygo-van-den-hurk/slyde

GHSA ID
GHSA-w7h5-55jg-cq2f
CVE ID
CVE-2026-26974
Severity
high
Published
Updated
CVSS v4
7.6 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Description

Impact

This is a remote code execution (RCE) vulnerability. Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file could execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages.

Patches

The issue has been patched in v0.0.5. Users should upgrade to v0.0.5 or later to mitigate the vulnerability.

Workarounds

  • Audit and restrict which packages are installed in node_modules.

References

CWEs

References