ua-parser/uap-core · Security
Denial of Service in uap-core
- GHSA ID
- GHSA-p4pj-mg4r-x6v4
- CVE ID
- CVE-2021-21317
- Severity
- high
- Published
- Updated
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS v3
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
Impact
Some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings.
Patches
Please update uap-core to >= v0.11.0
Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.
CWEs
- CWE-400 · Uncontrolled Resource Consumption
- CWE-1333 · Inefficient Regular Expression Complexity
References
- https://github.com/ua-parser/uap-core/security/advisories/GHSA-p4pj-mg4r-x6v4 ↗
- https://github.com/ua-parser/uap-core/commit/dc9925d458214cfe87b93e35346980612f6ae96c ↗
- https://www.npmjs.com/package/uap-core ↗
- https://nvd.nist.gov/vuln/detail/CVE-2021-21317 ↗
- https://github.com/advisories/GHSA-p4pj-mg4r-x6v4 ↗