voxpelli/node-connect-pg-simple · Security
SQL Injection in connect-pg-simple
- GHSA ID
- GHSA-xqh8-5j36-4556
- CVE ID
- CVE-2019-15658
- Severity
- high
- Published
- Updated
- CVSS
- 7.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CVSS v3
- 7.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Description
Impact
An unlikely SQL injection if the case of an unsanitized table name input.
Patches
The user should upgrade to 6.0.1. Due to its low impact a backport has not been made to the 5.x branch.
Workarounds
If there is no likelihood that the tableName or schemaName options sent to the constructor could be of an unsanitized nature, then no workaround is needed. Else the input could be sanitized and escaped before sending it in. Take note though that such an escaping would need to be removed when upgrading to 6.0.1 or later, to avoid double escaping.
References
For more information
If you have any questions or comments about this advisory:
- Open an issue in voxpelli/node-connect-pg-simple
- Email maintainer at [email protected]
CWEs
- CWE-89 · Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')