wikimedia/mediawiki · Security
MediaWiki Incorrect Access Control vulnerability
- GHSA ID
- GHSA-7mqg-5fgh-xh4r
- CVE ID
- CVE-2019-12472
- Severity
- high
- Published
- Updated
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CVSS v3
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
CWEs
- CWE-284 · Improper Access Control
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-12472 ↗
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html ↗
- https://phabricator.wikimedia.org/T199540 ↗
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12472.yaml ↗
- https://github.com/advisories/GHSA-7mqg-5fgh-xh4r ↗