yikesinc/yikes-inc-easy-mailchimp-extender · Security
yikes-inc-easy-mailchimp-extender Cross-site Scripting vulnerability
- GHSA ID
- GHSA-837v-6vgx-jqcc
- CVE ID
- CVE-2021-4244
- Severity
- medium
- Published
- Updated
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS v3
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
A vulnerability classified as problematic has been found in yikes-inc-easy-mailchimp-extender Plugin up to 6.8.5. This affects an unknown part of the file admin/partials/ajax/add_field_to_form.php. The manipulation of the argument field_name/merge_tag/field_type/list_id leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 6.8.6 can address this issue. The name of the patch is 3662c6593aa1bb4286781214891d26de2e947695. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215307.
CWEs
- CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-4244 ↗
- https://github.com/EvanHerman/yikes-inc-easy-mailchimp-extender/pull/889 ↗
- https://github.com/EvanHerman/yikes-inc-easy-mailchimp-extender/commit/3662c6593aa1bb4286781214891d26de2e947695 ↗
- https://github.com/EvanHerman/yikes-inc-easy-mailchimp-extender/releases/tag/6.8.6 ↗
- https://vuldb.com/?id.215307 ↗
- https://github.com/advisories/GHSA-837v-6vgx-jqcc ↗