zenml-io/zenml · Security
ZenML Server Remote Privilege Escalation Vulnerability
- GHSA ID
- GHSA-vf7j-cmrj-pmmm
- CVE ID
- CVE-2024-25723
- Severity
- high
- Published
- Updated
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CVSS v3
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CVSS v4
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
Description
ZenML Server in the ZenML package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
CWEs
- CWE-284 · Improper Access Control
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-25723 ↗
- https://github.com/zenml-io/zenml ↗
- https://www.zenml.io/blog/critical-security-update-for-zenml-users ↗
- https://github.com/zenml-io/zenml/compare/0.42.1...0.42.2 ↗
- https://github.com/zenml-io/zenml/compare/0.43.0...0.43.1 ↗
- https://github.com/zenml-io/zenml/compare/0.44.3...0.44.4 ↗
- https://github.com/advisories/GHSA-vf7j-cmrj-pmmm ↗